Chrome Update Required Due To Security Flaw

Due to a security flaw found in Google Chrome that can allows hackers to gain access to some computers, it is advised to check you are running the latest version 72.0.3626.121 and if not, update it now!

To check you have the latest version, follow these steps:

STEP 1.  Open Chrome

STEP 2. Click on the 3 vertical dots top right to access the menu and select Help > About Google Chrome or you can click on this link:

chrome://settings/help

If there is an update, Chrome will then automatically download and install the update for you before prompting you to restart Chrome to apply the update.

 



Leave a Reply